Can't find what you need?


• Ask the Community
• Create a Case
Reset Search
 

 

Article

How To Configure S-Series to Failover to Secondary and Tertiary ISP in a BGP Network

« Go Back

Information

 
TitleHow To Configure S-Series to Failover to Secondary and Tertiary ISP in a BGP Network
Objective
  • The sample below shows how to configure two backup ISP's using BGP MED settings.
  • The lab has 3 ISP routers each feeding a default route into the setup.
  • Router 1 has a connection to ISP 1 and 3 and Router 2 has ISP 2.
  • The default route now follows the desired path when disabling ISP links.
Environment
S-Series
Procedure
Router1 Config

S8 Chassis(su-Router1)->sh run
# **** VRF Router1 ****
set router vrf create Router1 context Router1
router Router1
configure terminal
!
route-map bgp ISP1 permit 10
match prefix-list any
set med 100
exit
route-map bgp ISP3 permit 10
match prefix-list any
set med 300
exit
!
interface vlan.0.101
ip address 10.1.1.2 255.255.255.0 primary
mac-address 00-1f-45-00-00-11
no shutdown
exit
interface vlan.0.301
ip address 30.1.1.2 255.255.255.0 primary
mac-address 00-1f-45-00-00-31
no shutdown
exit
interface vlan.0.400
ip address 40.1.1.1 255.255.255.0 primary
mac-address 00-1f-45-00-00-40
no shutdown
exit
!
!
router bgp 400
bgp router-id 40.1.1.1
bgp always-compare-med
log-up-down
neighbor 10.1.1.1 remote-as 100
neighbor 10.1.1.1 route-map ISP1 in
neighbor 30.1.1.1 remote-as 300
neighbor 30.1.1.1 route-map ISP3 in
neighbor 40.1.1.2 remote-as 400
redistribute connected
exit
!
ip prefix-list any seq 5 permit 0.0.0.0/0 le 32
!
!
exit
exit
!
S8 Chassis(su-Router1)->


Router2 config

S8 Chassis(su-Router2)->sh run
# **** VRF Router2 ****
set router vrf create Router2 context Router2
router Router2
configure terminal
!
route-map bgp ISP2 permit 10
match prefix-list any
set med 200
exit
!
interface vlan.0.201
ip address 20.1.1.2 255.255.255.0 primary
mac-address 00-1f-45-00-00-21
no shutdown
exit
interface vlan.0.500
ip address 40.1.1.2 255.255.255.0 primary
mac-address 00-1f-45-00-00-50
no shutdown
exit
!
!
router bgp 400
bgp router-id 40.1.1.2
bgp always-compare-med
log-up-down
neighbor 20.1.1.1 remote-as 200
neighbor 20.1.1.1 route-map ISP2 in
neighbor 40.1.1.1 remote-as 400
redistribute connected
exit
!
ip prefix-list any seq 5 permit 0.0.0.0/0 le 32
!
!
exit
exit
Additional notes

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255