Can't find what you need?


• Ask the Community
• Create a Case
Reset Search
 

 

Article

How to Configure an S/N/K/7100-Series and Securestack to Route Wake on Lan Packets

« Go Back

Information

 
TitleHow to Configure an S/N/K/7100-Series and Securestack to Route Wake on Lan Packets
Objective
How to Configure a router to pass wake on LAN packets
Environment
  • S-Series
  • K-Series
  • Securestack
  • N-Series
  • 7100-Series
Procedure

Vary the configuration to accommodate the server implementation. There are two scenarios, choose the one that fits your need:

A) If the server is sending a layer 3 directed broadcast, 10.10.10.255 then you need only to enable directed broadcast on the interface of the client subnet.
Interface vlan.0.2
ip addresss 10.10.10.1 255.255.255.0
no shutdown
ip directed-broadcast


or

B) If the server is sending layer two broadcast FF:FF:FF:FF:FF:FF, then you need to add a helper to the server interface and use the all protos command to have the ip forward protos command to tell the router to forward port 7 and 9.

1. Configure an ip-helper on the server interface VLAN
Interface vlan.0.1
ip address 10.1.1.1 255.255.255.0
ip helper address 10.10.10.255


2. configure the forward protos to allow port 7 and 9 to be broadcast by helper which is needed because WoL ports are not forwarded with the default helper address configuration.
ip forward proto udp 7
ip forward proto udp 9


3. Configure the directed broadcast on the client facing interface.
Interface vlan.0.2
ip address 10.10.10.1 255.255.255.0
no shutdown
ip directed-broadcast
Additional notes
Wake on LAN (WoL) Considerations in a Routed Network

For security write an ACL limiting directed broadcast to the sending server, example:

ip access-list extended WOL

permit udp host 203.0.113.23 any eq 7
permit udp host 203.0.113.23 any eq 9

deny udp any any eq 7
deny udp any any eq 9

permit ip any any
exit



On outgoing interface:

Interface  vlan.0.1
Ip access-group  WOL out

 

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255