Reset Search
 

 

Article

How to Configure anS-Series for Redundancy Between to BGP Peersand an OSPF Router inCase Both BGP Routers Fail

« Go Back

Information

 
TitleHow to Configure anS-Series for Redundancy Between to BGP Peersand an OSPF Router inCase Both BGP Routers Fail
Objective
The following config provides redundancy between two ISP routers and a third backup to an OSPF network. The 203.0.113.254 is preferred when everything is working because it has the highest local preference.

The ISP routers are in the same AS as the S-Series creating an IBGP link with a default weight of 200 which is configured to 100, so BGP is preferred over OSPF and the OSPF route will be used only if both BGP routers fail.If it were an EBGP peer the distance would be lower than OSPF by default.
The OSPF Routes are redistributed into BGP and the route-map filter and backup advertise all routes except the default  route  which is static and point to a  different firewall not involved in the redundancy.It is important to stop advertising the default route to the ISP to prevent the  network from becoming an Internet  transit link.  
Environment
S-Series
Procedure
NORTH(su)->show run
configure terminal
!
route-map bgp backup deny 15
match prefix-list default
exit
route-map bgp backup permit 20
match prefix-list any
exit
route-map bgp bigpipe permit 10
set local-preference 100
exit
route-map bgp filter deny 15
match prefix-list default
exit
route-map bgp filter permit 20
match prefix-list any
exit
route-map bgp littlepipe permit 10
set local-preference 50


!
interface loop.0.1
ip address 2.2.2.2 255.255.255.255 primary
exit
interface vlan.0.20
ip address 203.0.113.2 255.255.255.0 primary
no shutdown
exit
interface vlan.0.51
ip address 198.51.100.1 255.255.255.0 primary
no shutdown
exit
interface vlan.0.192
ip address 192.0.2.1 255.255.255.0 primary
no shutdown
exit
!
# Static routes configured on routed interfaces
ip route 0.0.0.0/0 198.51.100.2 interface vlan.0.51 1
ip route 22.22.0.0/16 198.51.100.77 interface vlan.0.51 1
!
!
!
router ospf 1
router-id 2.2.2.2
network 0.0.0.0 255.255.255.255 area 0.0.0.0
redistribute static
redistribute bgp
log-adjacency
exit
!
router bgp 1234
bgp distance internal 100
bgp router-id 2.2.2.2
log-up-down
neighbor 203.0.113.1 remote-as 1234
neighbor 203.0.113.1 route-map filter out
neighbor 203.0.113.1 route-map littlepipe in
neighbor 203.0.113.254 remote-as 1234
neighbor 203.0.113.254 route-map backup out
neighbor 203.0.113.254 route-map bigpipe in
redistribute static
redistribute ospf 1
exit
!
ip prefix-list default seq 5 permit 0.0.0.0/0
ip prefix-list any seq 5 permit 0.0.0.0/0 le 32
!
!

exit
!
NORTH(su)->
NORTH(su)->
Additional notes

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255