Reset Search
 

 

Article

How to Configure the S-Series to Connect to Xfinity-on-Campus using BGP

« Go Back

Information

 
TitleHow to Configure the S-Series to Connect to Xfinity-on-Campus using BGP
Objective
The following configs are being used to allow access to Xfinity-on-Campus streaming service by an EBGP connection. The Core 1 router is the existing router that uses OSPF to route to other internal routers and a static route to the firewall for internet access. The SSA router has been added to terminate the BGP connection to the Comcast router that will advertise the routes needed for the Xfinity-on-Campus routes, and advertise the campus routes to Comcast to allow Comcast to route directly to the school, not using the internet, and preventing asymetrical routing. The SSA also connects to the Core1 router using IBGP to advertise the Comcast routes to the Core.
  • College Campus public IP range is 198.51.100.0/24
  • The Comcast BGP router is 203.0.113.1/30
  • The onsite router interface peering with comcast is 203.0.113.1/30with a loopback of 2.2.2.2
  • The multihop peer is 203.0.113.5
  • The two S-Series are peering using IBGP to the loopback interface requiring the update source command be used to tell the peer to establish the BGP TCP session with a non local interface.
  • The soft configuration command is not required but a best practice recommendation.
  • OSPF is used as the interior routing protocol that routes between the two IBGP  Speakers for  connectivity to the loopback address for peering but static routes or RIP could be used as well.
  • The Comcast route-map advertises the customers network to comcast
  • The Multihop route-map filters all routes from the multihop peer.
  • There is a static route to the Multihop neighbor that is required for the session to become established.
  • The static rout is redistributed into OSPF so that the IBgP neighbor (Core 1) knows the route to the multihop neighbor
  • The SSA also has a multihop peer that is required for Comcast customers to access the Campus AS.
  • IP Address scheme and information,
  • The comcast AS number and Community are the same as the actual config but the other IP addresses have been changed.
Environment
  • S-Series
  • All firmware versions
  • Comcast Xfinity-on-Campus
Procedure
Router that Peers with Comcast
SSA Chassis(su-router)->
>show run
configure terminal
!
route-map bgp Comcast permit 10
match prefix-list PrefixComcast
set community 7922:999 set-specific
exit
route-map bgp MultiHop permit 15
match prefix-list DenyComcast
exit
!
interface loop.0.1
ip address 2.2.2.2 255.255.255.255 primary
no shutdown
exit
!
# Static routes configured on routed interfaces
ip route 203.0.113.5/32 203.0.113.5 interface vlan.0.4027 1
!
router ospf 1
router-id 2.2.2.2
network 0.0.0.0 255.255.255.255 area 0.0.0.0
redistribute static
log-adjacency
exit
!
router bgp 1234
bgp router-id 2.2.2.2
aggregate-address 198.51.100.0/24
log-up-down
neighbor 203.0.113.1 remote-as 7922
neighbor 203.0.113.1 soft-reconfiguration
neighbor 203.0.113.1 route-map Comcast out
neighbor 203.0.113.5 remote-as 7922
neighbor 203.0.113.5 ebgp-multihop 255
neighbor 203.0.113.5 route-map MultiHop out
neighbor 1.1.1.1 remote-as 1234
neighbor 1.1.1.1 soft-reconfiguration
neighbor 1.1.1.1 update-source 2.2.2.2
network 198.51.100.0/24
exit
!
ip prefix-list PrefixComcast seq 5 permit 198.51.100.0/24
ip prefix-list DenyComcast seq 11 deny 0.0.0.0/0

Core Router Config:
!interface loop.0.1
ip address 1.1.1.1 255.255.255.255 primary
no shutdown
exit
# Static routes configured on routed interfaces
ip route 0.0.0.0/0 198.51.100.1 interface vlan.0.1000 1
!
router ospf 1
router-id 1.1.1.1
network 0.0.0.0 255.255.255.255 area 0.0.0.0

router bgp 1234
bgp router-id 1.1.1.1
log-up-down
neighbor 2.2.2.2 remote-as 1234
neighbor 2.2.2.2 soft-reconfiguration
neighbor 2.2.2.2 update-source 1.1.1.1
exit
!
Additional notes

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255