Reset Search
 

 

Article

How to configure Policy-Based Routing on 200-Series switches

« Go Back

Information

 
TitleHow to configure Policy-Based Routing on 200-Series switches
Objective
In the following example a 220-Series switch is configured for routing on three VLAN interfaces
VLAN 10 - 10.10.10.1/24
VLAN 20 - 20.20.20.1/24
VLAN 30 - 30.30.30.1/24
And shows the configuration to policy route traffic with the specified characteristics from VLAN routing interface 30 to VLAN routing interface 10 i.e. source IP 30.30.30.10 to next hop 10.10.10.10
Environment
  • 220-Series switches
  • All firmware versions
  • Routing
  • PBR
Procedure
Create the VLANs and enable routing
 
vlan database
vlan 10,20,30
vlan routing 10 1
vlan routing 20 2
vlan routing 30 3
exit

Add ports to the VLANs and configure the PVID
 
interface 1/0/1
vlan pvid 10
vlan participation include 10
exit

interface 1/0/2
vlan pvid 20
vlan participation include 20
exit

interface 1/0/2
vlan pvid 30
vlan participation include 30
exit

Enable routing on VLAN interfaces
 
interface vlan 10
routing
ip address 10.10.10.1 255.255.255.0
exit

interface vlan 20
routing
ip address 20.20.20.1 255.255.255.0
exit

interface vlan 30
routing
ip address 30.30.30.1 255.255.255.0
exit

Globally enable IP routing
 
ip routing

Create the access-list to match the incoming traffic and the route-map to match
 
access-list 1 permit 30.30.30.10 0.0.0.255
route-map vlan10 permit 10
match ip address 1
set ip next-hop 10.10.10.10
exit

Add the route-map to routing interface 30
 
(Extreme 220) >enable
(Extreme 220) #configure
(Extreme 220)(Config)#interface	vlan 30
(Extreme 220) (Interface vlan 30)#ip policy route-map vlan10

Verify that traffic is being policy routed by checking that "Policy routing matches" counters are incrementing when the specified traffic is sent
 
(Extreme 220) #show route-map vlan10

route-map vlan10 permit 10
     Match clauses:
       ip address (access-lists) : 1
     Set clauses:
       ip next-hop 10.10.310.10
Policy routing matches: 306 packets, 0 bytes








 
Additional notes
For other route-map commands
match (length mac-list)
set ip (default next-hop precedence)
set interface

See the 200-Series CLI Guide
 

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255