Reset Search
 

 

Article

How to configure 6PE on MPLS PE routers?

« Go Back

Information

 
TitleHow to configure 6PE on MPLS PE routers?
Question

IPv6 Provider Edge (6PE) is one of the several approaches to provide IPv6 connectivity over an MPLScore without having the core devices torun IPv6.

6PE leverages IPv4/MPLS signaling plane to forward IPv6 traffic- it is actually a method to tunnel IPv6 traffic over IPv4 backbone and it is dynamic in nature beingMPLS based.

MP-BGP enables exchange of IPv6 prefixes between PE routers. The core routers and the LSP signaling protocols remain part ofthe MPLS infrastructure andare not aware or configured for IPv6.

The PE routers themselves are the next-hop for the IPv6 prefixes they advertise - the next-hop is a IPv4 mapped IPv6 address. A two label stack is allocated for each IPv6 prefix - the outer label represents the LSPto reach an egress PE and the inner label represents the IPv6 island that a 6PE router is connected to.

Environment
Answer

6PE is achieved with the following steps.

1. Exchange IPv6 reach ability information among 6PE routers with MP-BGP:
The 6PE routers exchange IPv6 prefixes over IPv4 MP-BGP sessions with a next-hop field that will be a IPv4 mapped IPv6 address. As well, the 6PEwill allocate a label to the IPv6 prefixes it connects to - theseassociated labels are used to forward traffic.

2. Transport IPv6 packets from the ingress 6PE router to the egress 6PE router over IPv4-signaled LSPs:
The ingress 6PE router forwards IPv6 traffic over a IPv4 LSP towards the egress 6PE router that resolves the IPv4 mapped IPv6 next-hop for the IPv6 prefix destination.

Here is a sample topology and the relevant configuration that enables 6PE. For simplicity, only the 6PE part of the configuration is provided and it is assumed that the MPLS/IGP infrastructure is already configured and operational.


IPv6-CE1----------[PE1]--------(MPLScloud)-------[PE2]-------IPv6-CE2

PE1's config snippet:
!
router bgp
local-as 65512
neighbor 2.2.2.2 next-hop-self
neighbor 2.2.2.2 update-source 1.1.1.1
neighbor 2001::2 remote-as 2001
!
address-family ipv6 unicast

neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-label

neighbor 2001::2 activate
exit-address-family
!

PE2's config snippet:
!
router bgp
local-as 65512
neighbor 1.1.1.1 remote-as 65512
neighbor 1.1.1.1 update-source 2.2.2.2
neighbor 1.2.3.4 remote-as 65512
neighbor 3001::2 remote-as 3001
!
address-family ipv6 unicast

neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-label

neighbor 3001::2 activate
exit-address-family


The 6PE specific commands are marked in red. The 6PE BGP neighborship differs from a standard IPv6 neighborship by:

  1. Sending MPLSlabels for each prefix advertised
  2. The next-hop for the advertised IPv6 prefixes will be the IPv6 mapped addresses i.e. the advertised next-hop by PE1 would be ::ffff:1.1.1.1 (where 1.1.1.1 is its IPV4iBGPpeering address).

IPv6 connectivity must exist between the PEand its CE. Any IPv6 supported routing protocol can run between them to exchange route information. If it's other than IPv6 BGP, then the PEmust explicitly redistribute those routes into BGP so as to advertise to its remote peers.

Useful CLIcommands:

With 6PE,some new commands are introduced and the output of a few existing commands are modified to display 6PE specific information.
The 6PE route updates carry a different SAFI(AFI=2, SAFI=4) which represents the capability to send labels - the outputs are modified to display this capability on the BGP neighbor session.


PE1#show ip bgp neigh 2.2.2.2
1 IP Address: 2.2.2.2, AS: 65512 (IBGP), RouterID: 164.122.0.1, VRF: default-vrf
[snip]
Neighbor NLRI Negotiation:
Peer Negotiated IPV4 unicast capability
Peer Negotiated IPV6 unicast capability
Peer configured for IPV4 unicast Routes
Peer configured for IPV6 unicast Routes

Neighbor ipv6 MPLS Label Capability Negotiation:
Peer Negotiated ipv6 MPLS Label capability
Peer configured for ipv6 MPLS Label capability

[snip]


The 'show ipv6 route' is added with a 'tags' option, which displays the labels associated with prefixes.
The sample output below is taken from PE2 - 2001:2::/64 is advertised by PE1, which is reachable via MPLS LSP 'v6' and the associated BGP next-hop is the IPv4 mapped address ::ffff:1.1.1.1

PE2#show ipv6 route tags
IPv6 Routing Table - 5 entries:
Type Codes - B:BGP C:Connected I:ISIS L:Local O:OSPF R:RIP S:Static
BGP Codes - i:iBGP e:eBGP
ISIS Codes - L1:Level-1 L2:Level-2
OSPF Codes - i:Inter Area 1:External Type 1 2:External Type 2
STATIC Codes - d:DHCPv6
Type IPv6 Prefix Next Hop Router Interface Dis/Metric Uptime src-vrf
1 Bi 2001:2::/64 :: lsp v6 200/1 15m37s -

label information: 794624(OUT)

PE-2#show ipv6 bgp 2001:2::/64
Number of BGP Routes matching display condition : 1
Status codes: s suppressed, d damped, h history, * valid, > best, i internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop MED LocPrf Weight Path
*>i 2001:2::/64 ::ffff:1.1.1.1 1 100 0 2001 i
Last update to IP routing table: 0h29m44s
Route is advertised to 1 peers:
3001::2(3001)

No new debug keywords are introduced with 6PE. The existing 'debug ipv6 bgp update' will display MP-BGP updates with the associated label value.

Note: 6PE functions in the default-vrf context i.e. the IPv6 CE peering cannot terminate in a VRF. 6VPE will support the requirement of the VRF connectivity.
Additional notes

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255