Reset Search
 

 

Article

How to leak a route between VRFs in NOS

« Go Back

Information

 
TitleHow to leak a route between VRFs in NOS
Question
Connectivity between VRF's are desired.

Environment
Answer
The current implementation of route leaking requires host to host routing. To allow connectivity between the PC and L3 interface on the Router requires the following configurations

!
interface Vlan 175
!
interface Vlan 249
!
rbridge-id 184
ip route 0.0.0.0/0 10.200.124.1
switch-attributes chassis-name VDX6740
switch-attributes host-name sw0
vrf mf
rd 1:1
address-family ipv4 max-route 3600
ip route 0.0.0.0/0 next-hop-vrf test 10.119.1.10
ip route 10.119.1.10/32 next-hop-vrf test 10.119.1.10
!
!
vrf mgmt-vrf
!
vrf test
rd 2:2
address-family ipv4 max-route 1200
ip route 0.0.0.0/0 10.119.1.10
ip route 10.111.75.10/32 next-hop-vrf mf 10.111.75.10
!
!
interface Ve 175
vrf forwarding mf
ip proxy-arp
ip address 10.111.75.252/24
no shutdown
!
interface Ve 249
vrf forwarding test
ip proxy-arp
ip address 10.119.1.252/24
no shutdown
!
!
interface TenGigabitEthernet 184/0/15
no fabric isl enable
fabric trunk enable
switchport
switchport mode access
switchport access vlan 175
spanning-tree shutdown
no shutdown
!
interface TenGigabitEthernet 184/0/16
no fabric isl enable
fabric trunk enable
switchport
switchport mode access
switchport access vlan 249
spanning-tree shutdown
no shutdown
!

Additional notes

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255