Reset Search
 

 

Article

VDX connected to a Cisco switch via Port-channel but Cisco always gives error: PM-SP-4-ERR_DISABLE: channel-misconfig error detected; why?

« Go Back

Information

 
TitleVDX connected to a Cisco switch via Port-channel but Cisco always gives error: PM-SP-4-ERR_DISABLE: channel-misconfig error detected; why?
Question
VDX and Cisco are directly connected via a single link port channel. In the confgs below, the VDX is setup to be root bridge for the 802.1w RSTP single instance. Cisco is setup for anMST single instance which is compatible with 802.1w RSTP. The VDX is intended to be the rootbridge for this topology. There s only vlan 99 in this topology and this is not intended to be an RSTP per vlan topology.

**On VDX there's a one member Port-channel, 1/0/45 currently part of PO-11

protocol spanning-tree rstp
bridge-priority 8192

interface Port-channel 11
vlag ignore-split
speed 1000
switchport
switchport mode trunk
switchport trunk allowed vlan add 99
no switchport trunk tag native-vlan
no spanning-tree shutdown
no shutdown

interface TenGigabitEthernet 1/0/45
speed 1000
no fabric isl enable
no fabric trunk enable
channel-group 11 mode active type standard
lacp timeout long
no shutdown


**On Cisco there's a one member Port-channel, 0/9 is currently part of PO-3 .

spanning-tree mode mst
spanning-tree extend system-id
!
spanning-tree mst configuration
name cisco
revision 1

interface Port-channel3
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 99
switchport mode trunk
speed 1000

interface GigabitEthernet0/9
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 99
switchport mode trunk
speed 1000
channel-group 3 mode active


---------------------------

Shortly after bringing up the port-channel interfacethe following logs appear in the Cisco and the port-channel will not come up.

.Oct 15 11:36:33.046: %PM-4-ERR_DISABLE: channel-misconfig error detected on Po3, putting Gi0/9 in err-disable state
.Oct 15 11:36:33.074: %PM-4-ERR_DISABLE: channel-misconfig error detected on Po3, putting Po3 in err-disable state
.Oct 15 11:36:34.050: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/9, changed state to down
.Oct 15 11:36:34.070: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel3, changed state to down
.Oct 15 11:36:35.074: %LINK-3-UPDOWN: Interface Port-channel3, changed state to down
.Oct 15 11:36:35.074: %LINK-3-UPDOWN: Interface GigabitEthernet0/9, changed state to down
.Oct 15 11:41:33.070: %PM-4-ERR_RECOVER: Attempting to recover from channel-misconfig err-disable state on Po3
.Oct 15 11:41:33.070: %PM-4-ERR_RECOVER: Attempting to recover from channel-misconfig err-disable state on Gi0/9
.Oct 15 11:41:37.558: %LINK-3-UPDOWN: Interface GigabitEthernet0/9, changed state to up
.Oct 15 11:41:43.306: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/9, changed state to up
.Oct 15 11:41:44.306: %LINK-3-UPDOWN: Interface Port-channel3, changed state to up
.Oct 15 11:41:45.082: %SPANTREE-2-PVSTSIM_FAIL: Blocking root port Po3: Inconsitent inferior PVST BPDU received on VLAN 99, claiming root 32867:0008.7c17.e400
.Oct 15 11:41:45.306: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel3, changed state to up
.Oct 15 11:42:59.536: %PM-4-ERR_DISABLE: channel-misconfig error detected on Po3, putting Gi0/9 in err-disable state
.Oct 15 11:42:59.564: %PM-4-ERR_DISABLE: channel-misconfig error detected on Po3, putting Po3 in err-disable state
.Oct 15 11:43:00.540: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/9, changed state to down
.Oct 15 11:43:00.560: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel3, changed state to down
.Oct 15 11:43:01.560: %LINK-3-UPDOWN: Interface Port-channel3, changed state to down
.Oct 15 11:43:01.564: %LINK-3-UPDOWN: Interface GigabitEthernet0/9, changed state to down
Environment
Answer
After egress port mirroring of VDX interface TenGigabitEthernet 1/0/45 we noticed the VDX was forwardingtwo BPDUs to Cisco; one was the expectedRSTP BPDUdirectly from the VDX itself but there wasalso an unexpected PVST+ BPDU from another cisco device on the network. When Cisco repeatedlysaw two BPDUs onthis port-channel it brought it down as err-disable. This is normal behavior for Cisco please see http://www.cisco.com/c/en/us/support/docs/lan-switching/etherchannel/20625-127.html

So why was Cisco receiving two BPDUs in the first place? Where was this PVST+ BPDU coming from?

Additional notes

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255