Reset Search
 

 

Article

What can be one of the reasons for IS-IS routes to show in the database but not populating in the route-table?

« Go Back

Information

 
TitleWhat can be one of the reasons for IS-IS routes to show in the database but not populating in the route-table?
Question
IS-IS Platforms MLX, XMR and CER.
Environment
Answer
Consider the following topology for the demonstration of the problem

MLX 1/1 --------------- 5/0/1 Cisco


MLXConfiguration is as follows:

default-max-frame-size 1618

router isis
net 49.0023.0061.0020.0015.00
auth-mode md5 level-2
auth-key 2 "$NlNeLVp8ODM=" level-2
fast-flood 4
is-type level-2
lsp-gen-interval 5
lsp-refresh-interval 65000
max-lsp-lifetime 65535
log adjacency
set-overload-bit on-startup 180
spf-interval level-1 5 1 100
spf-interval level-2 5 1 100
address-family ipv4 unicast
exit-address-family

address-family ipv6 unicast
exit-address-family

!

interface ethernet 1/1
enable
load-interval 30
ip router isis
ip address 23.61.100.70/30
ip pim-sparse
ip pim dr-priority 9999
ip mtu 1600
isis auth-mode md5
isis auth-key 2 "$NlNeLVp8ODM="
isis point-to-point

!

Cisco configuration:

router isis
net 49.0023.0061.0010.0001.00
is-type level-2-only
authentication mode md5
authentication key-chain isis_md5
ispf level-2
metric-style wide
fast-flood
set-overload-bit on-startup 180
max-lsp-lifetime 65535
lsp-refresh-interval 65000
spf-interval 5 1 100
prc-interval 5 1 100
lsp-gen-interval 5 1 100
log-adjacency-changes
nsf cisco
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2
!
interface GigabitEthernet5/0/1
dampening
mtu 1600
ip address 23.61.100.69 255.255.255.252
no ip directed-broadcast
ip pim sparse-mode
ip router isis
load-interval 30
carrier-delay msec 0
negotiation auto
tag-switching ip
isis network point-to-point
isis metric 230 level-2
isis authentication mode md5
isis authentication key-chain isis_md5_brocade
isis three-way-handshake ietf
service-policy output PHB/12000_GE/BB

key chain isis_md5_brocade
key 1
key-string 7 151F1B00177B79777C




IS-ISneighborship comes up fine without any issue and routes were there in the IS-ISDatabase but not getting installed in the routing table.

MLX#sh isis neighbor
Total number of IS-IS Neighbors: 1
System Id Interface SNPA State Holdtime Type Pri StateChgeTime Protocol
CORE6101 eth 1/1 0900.2b00.0005 UP 30 PTPT 127 0 :0 :0 :12 ISIS




MLX#sh isis database

IS-IS Level-2 Link State Database
LSPID Seq Num Checksum Holdtime ATT/P/OL
CORE1101.00-00 0x0000f777 0xf268 48919 0/0/0
EDGE1101.00-00 0x00000dfd 0x0ade 54194 0/0/0
EDGE1102.00-00 0x00000c2d 0x07b0 44642 0/0/0
EDGE1103.00-00 0x00000379 0x0644 26329 0/0/0
EDGE1104.00-00 0x00003ebe 0x0c56 22909 0/0/0
EDGE1105.00-00 0x00000df3 0x9936 48916 0/0/0
EDGE1106.00-00 0x000013a2 0x2f36 23084 0/0/0
EDGE1107.00-00 0x000006c4 0x03b1 21517 0/0/0
EDGE1108.00-00 0x0000096d 0x6a09 63259 0/0/0
EDGE1109.00-00 0x000004d9 0x2d4c 56431 0/0/0
EDGE1110.00-00 0x0000028c 0xc348 48417 0/0/0
EDGE1111.00-00 0x00000289 0x72e4 48449 0/0/0
EDGE1112.00-00 0x00000167 0xebe9 13478 0/0/0
REFL1101.00-00 0x00000bc8 0x1357 22335 0/0/1
CORE2101.00-00 0x0000a8bc 0xc268 65144 0/0/0
EDGE2101.00-00 0x0000a9ed 0x8d07 34803 0/0/0
EDGE2102.00-00 0x0000acf0 0xff61 34529 0/0/0
EDGE2103.00-00 0x0000ab34 0xa602 19340 0/0/0
EDGE2104.00-00 0x00003bc2 0xe8dd 56064 0/0/0
EDGE2106.00-00 0x000008f6 0xe79d 22447 0/0/0
LSPID Seq Num Checksum Holdtime ATT/P/OL
REFL2101.00-00 0x0000a4b2 0x6148 7810 0/0/1
EDGE2701.00-00 0x000025a4 0x4c94 16698 0/0/0
EDGE2702.00-00 0x00009b1a 0x1e79 48914 0/0/0
CORE3101.00-00 0x000048c8 0xdc49 43295 0/0/0
EDGE3101.00-00 0x00000621 0x413b 41703 0/0/0
EDGE3102.00-00 0x00001275 0xfb4f 15886 0/0/0
EDGE3103.00-00 0x0000026e 0xa7bd 48740 0/0/0
REFL3101.00-00 0x0000125e 0xe7b5 29741 0/0/1
DIST4101.00-00 0x00001c69 0x91e4 61087 0/0/0
EDGE4101.00-00 0x00000fc8 0xf946 54573 0/0/0
EDGE4102.00-00 0x00000de6 0xa160 44013 0/0/0
EDGE4103.00-00 0x000007e5 0xe5fb 16863 0/0/0
DIST4801.00-00 0x00003872 0x5ce4 14605 0/0/0
EDGE4801.00-00 0x00000d0e 0xe2e6 9939 0/0/0
EDGE4802.00-00 0x00000b76 0x340e 7813 0/0/0
DIST5101.00-00 0x00007497 0xe51f 13316 0/0/0
EDGE5101.00-00 0x00000bb3 0xef3a 44746 0/0/0
EDGE5102.00-00 0x00000c3d 0x5057 55227 0/0/0
EDGE5103.00-00 0x00002fc9 0x0d08 62132 0/0/0
EDGE5104.00-00 0x00000066 0x5a86 47603 0/0/0
CORE6101.00-00 0x000199ef 0x3047 65509 0/0/0
CORE6102-RE0.00-00 0x00001365 0x3ff0 58496 0/0/0
LSPID Seq Num Checksum Holdtime ATT/P/OL
CORE6103-RE0.00-00 0x00000b06 0x1b46 64065 0/0/0
EDGE6101.00-00 0x000014a9 0x4d91 22466 0/0/0
EDGE6102.00-00 0x00000246 0x8385 16873 0/0/0
EDGE6103.00-00 0x0000591e 0xab87 41361 0/0/0
EDGE6104.00-00 0x0002dca3 0xeed2 7219 0/0/0
EDGE6105.00-00 0x0000a928 0x55bb 52041 0/0/0
EDGE6106.00-00 0x00000229 0x0536 45928 0/0/0
EDGE6107.00-00 0x0000022e 0x21a5 44971 0/0/0
EDGE6108.00-00 0x0000024e 0x3718 31874 0/0/0
EDGE6109_PVLAN.00-00 0x00000167 0x9acd 29343 0/0/0
EDGE6112.00-00 0x000097d5 0x10ef 44532 0/0/0
EDGE6113.00-00 0x00000313 0xd222 31634 0/0/0
EDGE6115.00-00* 0x0000002c 0x1dde 65511 0/0/0
EDGE6120.00-00 0x00000225 0xcf94 6033 0/0/0
REFL6101.00-00 0x00000257 0x4ea6 39119 0/0/1
EDGE6201.00-00 0x000038e0 0xbba7 22744 0/0/0
EDGE6202.00-00 0x00000f10 0xf7c7 20307 0/0/0
EDGE6301.00-00 0x00000e72 0x3c5c 12019 0/0/0
EDGE6302.00-00 0x00000a6b 0x6e6f 20960 0/0/0
EDGE6501.00-00 0x00001551 0xfb84 9686 0/0/0
EDGE6502.00-00 0x00000b91 0x90bb 29744 0/0/0
EDGE6701.00-00 0x000018d4 0xcf9d 31382 0/0/0
LSPID Seq Num Checksum Holdtime ATT/P/OL
EDGE6702.00-00 0x00000acb 0x7c1e 28726 0/0/0
EDGE6801.00-00 0x00007550 0xd56b 17581 0/0/0
EDGE6802.00-00 0x000066a4 0xe957 37443 0/0/0
EDGE6901.00-00 0x00001655 0x311e 14160 0/0/0
EDGE6902.00-00 0x00000b35 0x4e7a 57950 0/0/0
DIST7101.00-00 0x000039a3 0x3fc2 47965 0/0/0
EDGE7101.00-00 0x00000d4c 0xb417 56047 0/0/0
EDGE7102.00-00 0x00001255 0xf106 44941 0/0/0
EDGE7901.00-00 0x0000477f 0x03b6 46117 0/0/0
EDGE7902.00-00 0x00004934 0x089a 65316 0/0/0
DIST8101.00-00 0x0000cde5 0xbbbf 36582 0/0/0
EDGE8101.00-00 0x00004f72 0xdc73 43037 0/0/0
EDGE8102.00-00 0x00004597 0x8282 60045 0/0/0
EDGE8103.00-00 0x00000a43 0x54bf 4051 0/0/0
EDGE8104.00-00 0x000001f1 0x8414 38639 0/0/0
EDGE8201.00-00 0x00000d51 0xbca2 26673 0/0/0
EDGE8202.00-00 0x0000097a 0xc11d 28448 0/0/0
EDGE8301.00-00 0x0000277a 0x746a 59792 0/0/0
EDGE8302.00-00 0x00001943 0xd5ce 13007 0/0/0
EDGE8401.00-00 0x00009a6a 0x3d75 15130 0/0/0
EDGE8402.00-00 0x00001709 0xa231 4651 0/0/0
DIST8501.00-00 0x000031c5 0xc33a 12941 0/0/0
LSPID Seq Num Checksum Holdtime ATT/P/OL
EDGE8501.00-00 0x000040f0 0x7346 11907 0/0/0
EDGE8502.00-00 0x000037ac 0x8ce4 16421 0/0/0
EDGE8503.00-00 0x000008af 0x2279 43757 0/0/0
EDGE8504.00-00 0x000005ef 0x951e 7763 0/0/0
EDGE8601.00-00 0x000002b4 0x74fc 2679 0/0/0
EDGE8602.00-00 0x000002be 0x1994 50244 0/0/0
DIST9101.00-00 0x00003de4 0xa57b 47168 0/0/0
EDGE9101.00-00 0x00001539 0xbf40 40997 0/0/0
EDGE9102.00-00 0x000019a7 0x3cba 60133 0/0/0
EDGE9103.00-00 0x00000140 0x8ea2 49056 0/0/0
EDGE9201.00-00 0x00041e03 0xbac1 58492 0/0/0
EDGE9202.00-00 0x000063c1 0xf423 35762 0/0/0
EDGE9501.00-00 0x00008544 0x064d 48462 0/0/0
EDGE9502.00-00 0x00000be8 0xaa4c 20214 0/0/0
EDGE9601.00-00 0x0000a1ec 0xfdde 44029 0/0/0
EDGE9602.00-00 0x00000f47 0x3ace 43930 0/0/0
EDGE9801.00-00 0x00000318 0xf130 6536 0/0/0
EDGE9802.00-00 0x00000ae4 0x5b3a 25536 0/0/0
CORE1102.00-00 0x00001e7a 0x71c4 48911 0/0/0
CORE1103.00-00 0x00000c20 0x654b 64063 0/0/0


MLX#sh ip route
Total number of IP routes: 2
Type Codes - B:BGP D:Connected I:ISIS O:OSPF R:RIP S:Static; Cost - Dist/Metric
BGP Codes - i:iBGP e:eBGP
ISIS Codes - L1:Level-1 L2:Level-2
OSPF Codes - i:Inter Area 1:External Type 1 2:External Type 2 s:Sham Link
STATIC Codes - d:DHCPv6
Destination Gateway Port Cost Type Uptime src-vrf
1 23.61.20.15/32 DIRECT loopback 1 0/0 D 11d3h -
2 23.61.100.68/30 DIRECT eth 1/1 0/0 D 11d3h -



On further debugging identified thatCiscois configured for a metric style wide which is used when configuring MPLSTE.On MLX default metric-typenarrow is enabledby default. Due to the metric-style mismatch between MLX and Cisco routes are getting installed inthe database but not in the routing table.

narrow

Use only the original IS-IS narrow metric style to build the IS-IS route table. Narrow metrics range from 0 to 63 (6 bits).

wide

Use the traffic engineering wide metric style to build the IS-IS route table. Wide metrics range from 0 to 17777215 (24 bits).



To check the metric-style use the following command sh isis and after configuring metric-style wide then routes got populate din the routing table.

router isis
address-family ipv4 unicast
metric-style wide
!
Additional notes

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255