Reset Search
 

 

Article

Why does the switchport link between VDX fabrics fail to come online?

« Go Back

Information

 
TitleWhy does the switchport link between VDX fabrics fail to come online?
Question
  • A user may attempt to configure a single switchport link between two VDXs or two VCS fabrics, but observe that the link fails to come online.
  • A user may attempt to configure a vLAGbetweentwo VCS fabrics, but observe that the link fails to come online.
  • A user may attempt to configure aport-channelbetween two VDXs or two VCS fabrics, but observe that the link fails to come online.

In the example below, the user is attempting to configure a port-channel between VDX3 and VDX1; note the link will fail to come online:

VDX3# show running-config interface Port-channel 10
interface Port-channel 10
vlag ignore-split
switchport
switchport mode trunk
switchport trunk allowed vlan all
switchport trunk tag native-vlan
spanning-tree shutdown
no shutdown
!

VDX3# show running-config interface TenGigabitEthernet 3/0/5
interface TenGigabitEthernet 3/0/5
no fabric isl enable
no fabric trunk enable
channel-group 10 mode active type standard
lacp timeout long
no shutdown
!

VDX1# show running-config interface Port-channel 10
interface Port-channel 10
vlag ignore-split
switchport
switchport mode trunk
switchport trunk allowed vlan all
switchport trunk tag native-vlan
spanning-tree shutdown
no shutdown
!

VDX1# show running-config interface TenGigabitEthernet 1/0/5
interface TenGigabitEthernet 1/0/5
no fabric isl enable
no fabric trunk enable
channel-group 10 mode active type standard
lacp timeout long
no shutdown
!



Note the line protocol is down, due to "ISL down":

VDX3# sho int te 3/0/5
TenGigabitEthernet 3/0/5 is up, line protocol is down (ISL down)
Hardware is Ethernet, address is 0027.f89c.2e48
Current address is 0027.f89c.2e48
Pluggable media not present
Interface index (ifindex) is 13287718916

VDX1# sho int te 1/0/5
TenGigabitEthernet 1/0/5 is up, line protocol is down (ISL down)
Hardware is Ethernet, address is 0027.f817.0f2e
Current address is 0027.f817.0f2e
Pluggable media present
Interface index (ifindex) is 4701978629


Environment
Answer
In summary, by default when two VDXs, which are VCS enabled are connected they will attempt to form a fabric using low level primitives and Brocade Link Discovery Protocol (BLDP).
If the VCS-ids match, along with other requirements the VDXs will form a VCS fabric.
In this case, though the customer disabled the fabric isl enable on the interface, this does not stop the low level primitives from being sent, thus detecting the neighboring VDX.
The only difference between the no fabric isl enable command and shutdown command is that the physical link remains up or is brought down, respectively.

The interfaces are ISL down because the user is attempting to bring up a NON-ISL link between VDXs with the same VCS-ids.
When attempting to create NON-ISL link between 2 VCS fabrics it is required that the VCS IDs differ.

Additional notes

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255