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COM VPFM IPFM AFO: Error "The page isn't redirecting properly" After Successful Installation Of Application

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TitleCOM VPFM IPFM AFO: Error "The page isn't redirecting properly" After Successful Installation Of Application
Symptoms
  • Unable to launch application COM/VPFM/IPFM after successful installation
  • For EFO/AFO, the issue is noticed suddenly with no changes being made to the application.
  • An error message is displayed on the browser window.
  • Launching the application from the server or client machine results in the same error.
  • Using a compatible version of the browser also displays the same error.
  • The error message received in Mozilla Firefox Browser is: "The page isn't redirecting Properly". Screen Shot below for reference:
User-added image
Environment
  • Configuration and Orchestration Manager running any supported software version
  • Visualization and Performance Manager running any supported software version
  • IP Flow Manager running any supported software version
  • Avaya/Extreme Fabric Orchestrator
  • Software version 1.1
Cause
  • For COM, VPFM or IPFM, the issue is due to incorrect entries of the FQDN (Fully Qualified Domain Name) in the “hosts” file.
  • By the time of writing this KB article, the cause for this issue on AFO/EFO is not known yet
Resolution

For COM/VPFM and IPFM:

  1. Uninstall the application and remove the “Avaya” directory from the installation directory.  
  2. Before re-installing the application, define the host file entries with the proper format as specified below.
    • For RHEL (Red Hat Enterprise Linux) platform check host file entry in "/etc/hosts" file.  
    • For Windows platform check host file entry in "C:\Windows\System32\Drivers\etc\hosts" file.
  3. The Correct format of FQDN is as below :
127.0.0.1          localhost
<X.X.X.X>            rhino.acme.com          rhino

In the above example :
  • "rhino” is the system name
  • “acme.com” is domain name
  • <X.X.X.X> is the IP address of the server

NOTE: Corrections performed after the installation will not resolve the issue. All the steps should be followed sequentially as mentioned above.

For AFO/EFO:

As part of the initial troubleshooting, upgrade the appliance to version 1.2 and check. If the issue is still not fixed after the upgrade, contact GTAC
Additional notes

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