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Extreme Guest & IoT Manager Internal Provisioner Login Failure Due To Local Password Repository Password Hash Type Mismatch

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TitleExtreme Guest & IoT Manager Internal Provisioner Login Failure Due To Local Password Repository Password Hash Type Mismatch
Symptoms
  • A login attempt via the provisioner portal using an internal provisioner account does not succeed.
  • Other internal provisioner accounts stored in the same password repository do succeed.
  • Accounts are created either directly in Extreme Control or via Guest & IoT Manager administrative GUI's.
Environment
  • Extreme Control (NAC)
  • Extreme Guest & IoT Manager (GIM)
  • All Software Releases
Cause
The internal provisioner account's Password Hash Type in the local password repository is set to "SHA1 non-reversible hash" versus default "PKCS5 reversible hash".
Resolution
Change the internal provisioner account to use the "PKCS5 reversible hash" method and reset the password via the Extreme Control GUI.
Additional notes
Guest & IoT Manager (GIM) creates internal provisioner accounts using the PKCS5 password hash. While switching from PKCS5 to SHA1 within Extreme Control is possible if the internal provisioner account password is updated via the Guest & IoT Manager admin GUI it sets a PKCS5 password hash in a field expecting a SHA1 hash type.

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