Reset Search
 

 

Article

SummitX 30.3.1.6 Firmware Image Using Incorrect Build String Incompatible with Extreme Management Center

« Go Back

Information

 
TitleSummitX 30.3.1.6 Firmware Image Using Incorrect Build String Incompatible with Extreme Management Center
Symptoms
  • Firmware upgrade/downgrades via Extreme Management Center do not complete as expected.
  • Onboarding Summit-series switches via ZTP+ does not complete as expected.
  • Firmware upgrade/downgrades via SCP, assigning image summitX-30.3.1.6.xos results in SSH XMOD warning that does not apply TO firmware version
  • Error message:
These devices are managed via SSH, but a SSH XMOD of the same version could not be found.
After updating the XOS firmware, make sure to update the SSH XMOD on these devices BEFORE resetting them.
Resetting a device before upgrading the SSH XMOD will result in a loss of connection to that device.
Environment
  • Extreme Management Center (XMC, formerly NetSight)
  • Summit-Series
  • EXOS
  • SSH
  • 30.3.1.6
Cause
Incorrect build string in summitX-30.3.1.6.xos build.
Resolution
ExtremeXOS devices on which firmware version 30.3.1.6 is installed do not download and install new firmware versions successfully via the ZTP+ process. To correct the issue, access the Network > Firmware tab in Extreme Management Center, select the ExtremeXOS device you are updating via ZTP+, and change the Version field from builds/xos_30.3/30.3.1.6 in the Details right-panel to 30.3.1.6.
 
Additional notes

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255