Reset Search
 

 

Article

Brocade Switch Stuck In Boot Loop Indicated By Solid Amber Lights

« Go Back

Information

 
TitleBrocade Switch Stuck In Boot Loop Indicated By Solid Amber Lights
Symptoms
  • Solid amber lights were being displayed on VDX6740.
  • The following errors are being logged and repeated in the log 4 to 6 times the the VDX will reboot.
hub_port_reset: resetting port 0 SCSI_REQ_SENSE failed failed cmd 0x03 returned 0x70 
0x06 0x28 0x00 Status: Stalled It will repeat this error 4 to 5 times before rebooting again
  • After changing the boot partition the above message still continued and a reboot will occur again.
Environment
  • XBR-VDX6740-24-F
  • NOS-6.2
Cause
The Compact Flash card stores the NOS software and system configuration data. The ECC errors appear to be caused by excessive copy-back operations. Copy-back operations invoke a data write with no error correction. The intent is that errors are corrected on the next read. Multiple operations with no read can accumulate enough errors (>4) that it becomes uncomfortable. This is a known issue with Compact Flash technology.

The unit fails and is found continuously rebooting. Most common is a failure during a firmware upgrade operation, but it has been observed at other times as well. The following error messages may be found in the Console log, which may indicate the issue, however, the only difference between the messages is where the error was encountered:
 
    SCSI_REQ_SENSE failed cmd 0x03 returned 0x70 0x06 0x28 0x00
    vsmgr: disk xfer failed for IO

NOTE:  The commonly seen “Hypervisor Reset Flush” message when seen alone is not indication of any error. However, in conjunction with any of the above errors in the Console log, this indicates the failure.

 
Resolution
When these failures occur the device will be unusable and requires an RMA replacement
Additional notes
Software Affected
NOS code versions prior to the fixed versions noted below, in the “Solution” section.

Workaround
We recommend customers to upgrade the VDX 6740, VDX 6740T and VDX 6740T-1G to the software releases with the software code change as noted in the below Solution section. Customers upgrading their VDX fabrics should work on preliminary steps well in advance with their Extreme GTAC Support team to minimize the risk of this type of failure happening during the upgrade process. Note: Refer to this Knowledge Article: NOS Firmware Upgrade Best Practices

We have identified an area in software which has a Compact Flash access pattern that could lead to excessive copy-back operations and hence possibly unrecoverable ECC errors. To help reduce the probability of failure due to excessive copy-back operations, we are providing a software update which reduces the number of writes to the Compact Flash by ten-fold during normal operations.
We expect the software update to fix and eliminate the risk of the ECC errors. These code changes are noted by DEFECT 000659778 and 000659781 in the Release Notes.

Solution
We have identified an area in software which has a Compact Flash access pattern that could lead to excessive copy-back operations and hence possibly uncorrectable ECC errors. To help reduce the probability of failure due to excessive copy-back operations, we are providing a software update which reduces the number of writes to the Compact Flash by ten-fold during normal operations. We expect the software fix to significantly minimize and potentially eliminate the risk of the ECC errors. These code changes are noted by DEFECT 000659778 and 000659781 in the Release Notes.
 
This software update is included in following versions:
NOS 7.3.0, 6.0.2h, 7.2.0a1, 7.1.0b2, 7.0.2b
 

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255