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Cannot log in via SSH on first attempt with correct password

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TitleCannot log in via SSH on first attempt with correct password
Symptoms
When logging into a switch via SSH with a RADIUS account, the password must be entered correctly twice to log in. 
 
bash-4.1$ ssh admin@192.168.1.1
harish@192.168.1.1's password:
Permission denied, please try again.
admin@1192.168.1.1's password:
ExtremeXOS
Copyright (C) 1996-2016 Extreme Networks. All rights reserved.
This product is protected by one or more US patents listed at http://www.extremenetworks.com/patents along with their foreign counterparts.
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Remember to save your configuration changes.


* X460G2-24t-10G4.1 #

 
Environment
  • EXOS 16.2 and 21.1
  • RADIUS Authentication
  • RADIUS Accounting
  • SSH
Cause
Due to an issue with how SSH handles RADIUS accounting, the first login attempt is incorrectly interpreted by the switch as a failed login. A second attempt is needed to actually log in.
Resolution
As a workaround, disabling RADIUS accounting and restarting the SSH process will resolve this issue. However, if RADIUS accounting is re-enabled this will occur again.
 
disable radius-accounting mgmt-access
restart process exsshd


A permanent fix (which will allow RADIUS accounting to be used) is scoped to be included in the following EXOS releases, via CR xos0066758:
  • EXOS 22.3.1
  • EXOS 22.2.1
  • EXOS 21.1.3
  • The February 2017 patch of EXOS 16.2.2
Additional notes

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