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Captive portal registration fails after NetSight restore or NetSight VM snapshot restore

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Information

 
TitleCaptive portal registration fails after NetSight restore or NetSight VM snapshot restore
Symptoms
  • Captive portal registration page looks after end system completes registration
  • New end system group entries in EAC are not reflected on in the EAC DB 
The following logs may be seen if debug is enabled on the EAC:
2017-03-21 16:19:01,119 DEBUG [NacApplGroupPersistence] Flagging Group: Registered Guests as out of sync, total queue: 1, reason: New revision: 63000 is not equal to current revision: 63187 and there are currently no queued updates.
2017-03-21 16:19:01,119 DEBUG [NACApplianceWebServiceImpl] NACAppliacneWebServiceImpl.pollTag last reachable: true, was timeout: false
2017-03-21 16:19:11,120 DEBUG [ResyncGroupWorker] Not running resync, updates have caught up for Group: Registered Guests, resyncToGetRev: 63000, currentRevision: 63187


 
Environment
  • Extreme Management Center
  • Extreme Control
Cause
EMC and EAC communicate each other updating end system groups dynamically based on updates that contain sequence numbers. When EMC is rolled back to a previous database, or a snapshot is restored the revision numbers are rolled back as well. When EAC receives an update with a revision number that is lower than it's last known sequence number it believes it's information is more current and doesn't perform the update.


 
Resolution
After any database restore or VM snapshot roll back of the EMC server an enforce is required to sync the revision numbers between the EMC and EAC. The enforce may not be flagged but is necessary or else updates will continue to be dropped.
Additional notes

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