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Extreme Portal Home pages report a Problem Loading

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TitleExtreme Portal Home pages report a Problem Loading
Symptoms
  • Some portal landing pages eventually display an error message instead of displaying formatted user data.
  • Service Contracts Home displays correctly, but Assets Home and Licenses Home hang/thrash/churn for awhile before issing an error message.
  • The portal's Assets Home page displays error message
    There was a problem loading your assets. Please try again later or create a case using the button below.
    [ Create a Case ]
  • The portal's Licenses Home page displays error message
    There was a problem loading your vouchers. Please try again later or create a case using the button below.
    [ Create a Case ]
Environment
Extreme Networks Portal
Cause
Assets are portal-listed if they are aligned to the user's company or aligned to a service contract citing the user's company:
Unable to View company's Assets in the Extreme Portal

Licenses are portal-listed if their asset meets the above-stated standard or they were redeemed by the user's company:
Exos/EOS/WiNG License Visibility guidelines for the Portal Licensing Home Page

The described performance issue can occur when a large amount of data - many asset/license records - must be parsed in order to build the page view for the portal user.
Resolution
As of May 2018 there is no immediate performance fix and no apparent workaround.
Resolution will require a significant redesign effort. This is underway, but there is no available estimate as to when the fix will be implemented.

As of November 2018 this issue is apparently resolved. Please report any recurrence.
Additional notes

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