ExtremeCloud Switch never checking in for the first time it's connected (red - down for check-in)
Symptoms
ExtremeCloud ExOS Switch is showing red (down) for check-in status
ExtremeCloud 220 is no longer accessible through the ExtremeCloud interface
ExtremeCloud Switch never checking in for the first time it's connected
Environment
ExtremeCloud
Extreme Management Center
Extreme 220
220-12P-10GE2
X440-G2-12p-10GE4
Firmware 1.1.2.10
Cause
The switch is resolving a local Extreme Management Center server on the network, once this happens the switch will not try and connect to the ExtremeCloud even if Extreme Management Center is not configured to talk to the switch.
Resolution
Make sure that there are no ExtremeControl servers that are accessible to the switch
Correct ExtremeCloud DNS resolution:
Additional notes
PLEASE NOTE: All cloud-connected switches must not have a local configuration on them, the ExtremeCloud will push the config down to your switch.
If making this change doesn't resolve the issue, login to the switch via serial and clear the configuration by using the "clear config" command. This will reset the switch and allow the CloudConnector to talk to ExtremeCloud.