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FN412 - EXOS 21.1.1 Patch 1-2 will not forward traffic with default configuration

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TitleFN412 - EXOS 21.1.1 Patch 1-2 will not forward traffic with default configuration
Symptoms

Summary:

EXOS 21.1.1 Patch 1-2 will not forward traffic with default configuration

Background:

EXOS 21.1.1 Patch 1-2 includes Zero-Touch Provisioning (ZTP), an EXOS Application which enables a cloud capable switch to participate in ExtremeCloud.  This application incorrectly disables flooding which prevents DHCP, ARP, and other important packets from being forwarded, and it prevents a client attached to the switch from obtaining an IP address via DHCP.
This will occur on an affected device with no configuration in a network with DHCP. This will not be an issue when ExtremeManagement 7.0 is being used to discover and configure devices.

Impact:

Within 5 minutes of booting, the switch will not forward traffic and will not allow connected client to obtain IP address via DHCP.
Environment

Affected Products:

All switches (without an existing configuration) which are upgraded to EXOS 21.1.1.4 patch 1-2 are affected.
 
The following switches have EXOS 21.1.1.4 Patch 1-2 or EXOS 21.1.1.4 Patch 1-3 installed at the factory, and are susceptible to this issue:
ProductProduct SKUManufacturing Number / Revision (EXOS 21.1.1.4 Patch 1-2)Manufacturing Number / Revision (EXOS 21.1.1.4 Patch 1-3)
X440-G2-12t-10GE416530908221-10  /  Rev06908221-10  /  Rev07
X440-G2-12p-10GE416531908222-10  /  Rev06908222-10  /  Rev07
X440-G2-24t-10GE416532908223-10  /  Rev06908223-10  /  Rev07
X440-G2-24p-10GE416533908224-10  /  Rev06908224-10  /  Rev07
X440-G2-48t-20GE416534908225-10  /  Rev08908225-10  /  Rev09
X440-G2-48p-10GE416535908226-10  /  Rev08908226-10  /  Rev09
X440-G2-24t-10GE4-DC16536908227-10  /  Rev06908227-10  /  Rev07
X440-G2-48t-10GE4-DC16537908228-10  /  Rev08908228-10  /  Rev09
X440-G2-24x-10GE416538908229-10  /  Rev06908229-10  /  Rev07
X440-G2-24fx-GE416539908230-10  /  Rev06908230-10  /  Rev07
X440-G2-12t-8fx-GE416540908231-10  /  Rev06908231-10  /  Rev07
X440-G2-24t-GE416541908232-10  /  Rev06908232-10  /  Rev07
    
X620-16x-Base17401908261-10 / Rev07908261-10 / Rev08
X620-16t-Base17402908262-10 / Rev08908262-10 / Rev09
X620-10x-Base17404908264-10 / Rev07908264-10 / Rev08
X620-8t-2x-Base17405908265-10 / Rev07908265-10 / Rev08
Cause

Root Cause:

The latest EXOS release (21.1.1.4 Patch 1-2) includes Zero Touch Provisioning (ZTP), a new EXOS application to enable ExtremeCloud for supported switches. The application automatically executes when a DHCP packet is received. ZTP immediately disables ‘all_cast” flooding (to avoid loops).
In a network with DHCP, an affected switch (with no configuration) will automatically run ZTP which disables “all_cast” flooding on all ports (typically within 5 minutes of booting). This results in basic switching functionality no longer working (e.g. DHCP, ARP, etc...). Clients will no longer be able to connect to the switch and get an IP address via DHCP, and the switch will appear to no longer be forwarding traffic. If this problem is present, the “disable flooding” command will be seen in the output of show configuration vlan for all ports:

disable flooding all_cast port 1
disable flooding all_cast port 2
disable flooding all_cast port 3
etc…

 
A software upgrade is required to resolve the automatic disabling of flooding.  The next EXOS 21.1.1 patch release will include a fix (however, it is not currently available).

NOTES:
  • Upgrading a switch with an existing configuration to EXOS 21.1.1.4 Patch 1-2 will not produce this issue.
  • This will not be an issue when ExtremeManagement 7.0 is being used to discover and configure devices.

Symptom:

  • No traffic is being forwarded through the switch
  • Unable to communicate with devices through the switch
  • Client unable to obtain IP address via DHCP
Resolution

Workaround:

Re-enable “all_cast” flooding (normally the default):
      enable flooding all_cast ports all
 
NOTE: This will need to be performed via the console or management port.

Solution:

This software defect is fixed in EXOS 21.1.1 Patch 1-5, which is available on eSupport.

!! Important
With patch 1-5, if the switch boots and the following conditions are true, ZTP can still disable flooding after it can resolve extremecontrol (DNS) and can connect to EMC (Netsight)
1. controller can dns resolve "extremecontrol[.searchdomain]", "extremecontrol.extremenetworks.com" or "devices.extremenetworks.com"
2. If one of these is responding then try to connect to it
3 disable flooding



For More Information contact Extreme Networks Global Technical Assistance Center (GTAC) http://support.extremenetworks.com
 
Additional notes
Legal Notice:
This advisory notice is provided on an “as is” basis and Extreme Networks makes no representations or warranties of any kind, expressly disclaiming the warranties of merchantability or fitness for a particular use. Use of the information provided herein or materials linked from this advisory notice is at your own risk. Extreme Networks reserves the right to change or update this document at any time, and expects to update this document as new information becomes available. The information provided herein is applicable to current Extreme Networks products identified herein and is not intended to be any representation of future functionality or compatibility with any third-party technologies referenced herein. This notice shall not change any contract or agreement that you have entered into with Extreme Networks. 

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