Reset Search
 

 

Article

Former Brocade TSB 2017-260-A - VDX 6940-144S, VDX 6940-64S, and VDX 6940-96S with a newer hardware component needs a NOS version where the uboot fixes exist.

« Go Back

Information

 
TitleFormer Brocade TSB 2017-260-A - VDX 6940-144S, VDX 6940-64S, and VDX 6940-96S with a newer hardware component needs a NOS version where the uboot fixes exist.
Symptoms
  • Firmware download to non uboot fix NOS version [Ex: NOS7.0.1c] will NOT be supported and blocked
sw0# firmware download [default-config] scp user <UN> password <PW> host 10.10.10.10 directory <ImageDir>/nos7.0.1c 
Performing system sanity check... 
A newer hardware component has been detected, thus firmware download is blocked to avoid degrading the system performance of the BR-VDX6940-144S platform. 
The preinstall script failed. 
sw0#
  • Firmware download to uboot fix NOS version [Ex: NOS7.2.0] is supported
sw0# firmware download [default-config] scp user <UN> password <PW> host 10.10.10.10 directory <ImgaeDir>/nos7.2.0/
Performing system sanity check...
 
This command will cause a cold/disruptive reboot and will require that existing telnet, secure telnet or SSH sessions be restarted.
Do you want to continue? [y/n]:
  • Last 2 digits of the show chassis command are 11 or higher which indicates a newer hardware component
    sw0# show chassis
    …
    Factory Part Num: 40-1001106-11
Environment
  • DEFECT(S):643669, 644087, 645838
  • Affected Network OS releases
    NOS6.0.2, NOS6.0.2a, NOS6.0.2b, NOS6.0.2c, NOS6.0.2d, 
    NOS6.0.2e, NOS7.0.0, NOS7.0.0a, NOS7.0.0b, NOS7.0.1, 
    NOS7.0.1a, NOS7.0.1b, NOS7.0.1c, NOS7.1.0, NOS7.1.0a
  • VDX6940 models with newer hardware components
    • VDX 6940-64S
    • VDX 6940-96S
    • BR-VDX6940-144S
Cause
Newer DRAM in VDX Factory Part Num: 40-1001106-11 are not compatible with SW versions below NOS 6.0.2f, NOS 7.2.0 & NOS7.1.0a2 and will result in an error when trying to downgrade to an unsupported non-uBoot NOS version. 
To identify a newer hardware component, execute “show chassis” CLI and verify Factory Part Num, if the last 2 digits are 11 or higher then it is running with the affected hardware component as below.
Resolution
  • Upgrade to any of the NOS releases below which have the uboot fix .
    • NOS 6.0.2f
    • NOS 7.0.1c1
    • NOS 7.0.2
    • NOS 7.1.0b
    • NOS 7.2.0
Additional notes
Software Upgrade/Downgrade Considerations
  • Please do not use "firmware install" CLI for NOS version upgrade or downgrade on BR-VDX6940-144S,  VDX 6940-96S or  VDX 6940-64S with a newer hardware component, as it will not block firmware download to non uboot fixed NOS version
  • For cluster wide firmware upgrades, if the VCS cluster has a variety of products including affected products with a newer hardware component, it is recommended to check the “Factory Part Num” using the command shown above and identify the vulnerability with this issue on any VDX6940 affected product(s).

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255