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Identity Engines: Guest IoT Manager SMTP Email Notification Delivery Failures

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TitleIdentity Engines: Guest IoT Manager SMTP Email Notification Delivery Failures
Symptoms
  • SMTP-based E-mail Notifications may not be successfully delivered.
  • Provisioners will be able to successfully create the user or device record however the following warning may be presented:
"Warning: New guest user 'user' was successfully created by 'user@domain.com' because generic error occurred"
  • Provisioners will be able to successfully create the user or device record however the following error may be presented:
"Warning: Guest user account "user" was successfully created but no password text message was sent because of exception: null"
Environment
  • Identity Engines Guest & IoT Manager (formerly Guest Manager)
  • All 9.x Software Releases
  • SMTP
Cause

System misconfiguration.

"because generic error occurred"

  • One or more configuration attributes in the Guest Manager E-mail settings are not properly set in system configuration files.

"because of exception: null"

  • Generally occurs following import of a backup configuration during upgrade between major releases.
  • Also occurs if there is a mismatch in authentication requirements between Guest Manager and SMTP server.
Resolution

Resolve each symptom using the steps noted below:

"because generic error occurred"

  1. Via the admin web interface, click Administration -> Notification -> E-mail.
  2. Confirm the settings are correct and click "Submit".
  • This should set required configuration attributes in system configuration files.

"because of exception: null"

  • User authentication to the SMTP server may be required. If user authentication is not checked or if the credentials provided are not correct, confirm appropriate settings and click "Submit".
Additional notes

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