Reset Search
 

 

Article

In a two-tier MLAG setup, L3 traffic stops working when disabling certain ports in the sharing

« Go Back

Information

 
TitleIn a two-tier MLAG setup, L3 traffic stops working when disabling certain ports in the sharing
Symptoms
  • In a two-tier MLAG setup, L3 packets does not egress out of a link (with sharing enabled) present on another units/slots.
     

Environment
  • BD8800

  • 15.6.3.1 Patch 1-8

Cause
  • The issue only occurs if the egress vlan contains another load sharing port which is present in the same unit of the port.

  • ​The interface associated with the corresponding L3 entry in hardware had the L2_switch bit set to 0, thus causing the issue.

  • Modifying it to L2_switch = 1 eliminated the issue and we were able to see that the ping worked fine.

  • This setting (L2 switch) comes into play as a result of the IP ARP distributed mode being ON.

* (pacman debug) BD-8810.3 # j h p b s 1 u 1 "l3 defip show ip=10.1.1.3"
Unit 1, Total Number of DEFIP entries: 262144
Free DEFIP entries: 262138
Max number of ECMP paths 4
#     VRF     Net addr             Next Hop Mac        INTF MODID PORT HIT
131074 2      10.1.1.3/32          00:04:96:98:4b:74   4094   T     64   y                        (NH Table index = 4)
196610 2      10.1.1.0/24          00:00:00:00:00:00   4095    4     0   n      (LOCAL ROUTE)     (NH Table index = 1)
4097   2      10.1.1.3/32          00:04:96:98:4b:74      1   T      0   y                        (NH Table index = 5)

* (pacman debug) BD-8810.4 # j h p b s 1 u 1 "l3 intf show"
Free L3INTF entries: 4091
Unit  Intf  VRF Group    VLAN    Source Mac     MTU TTL Tunnel InnerVlan L2
------------------------------------------------------------------------
1     1     2     0     4090 00:04:96:1e:9c:f0  16383 1    0     0     0
1     2     2     0     4093 00:04:96:1e:9c:f0  16383 1    0     0     0
1     4093  2     0     4093 00:04:96:1e:9c:f0  16383 1    0     0     1
1     4094  2     0     4090 00:04:96:1e:9c:f0  16383 1    0     0     0

  • For collecting debug outputs mentioned above, we need to involve GTAC to provide the debug password.
Resolution
  • As a workaround, we can turn off distributed ARP mode.

  • Kindly track this issue via CR# xos0063161 - with "distributed ARP-mode + LAG" packets are getting dropped across unit.

  • If any further queries, please contact GTAC for assistance.

Additional notes

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255