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Java client does not launch application after upgrading Extreme Management Center (Netsight) to version 8.02.42

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TitleJava client does not launch application after upgrading Extreme Management Center (Netsight) to version 8.02.42
Symptoms
Environment
  • Netsight
  • Extreme Management Center
  • Java
  • Version 8
  • Analytics
Cause
Please gather the following: IF the two below Resolutions do not address the issue.

Issue the following command in a Windows command prompt, OS X terminal, or Linux bash to get Java Version
java -version

Gather the operating system version, with specific build. with the command:

Windows 
systeminfo

Linux:
cat os-version
or
uname -a

MAC OS X 
sw_vers

Gather the following text file from the client having issues connecting to NetSight
C:\Users\xxxxxx\AppData\Roaming\Netsight\logs\console.log (this may need to be a hidden directory in Users home directory)

Gather the Java Control Panel Information 

From Windows:
Start->Control Panel->Java->Advanced->Screenshot Advanced Security Settings, towards the bottom of advanced tab

From MAC OS:
System Preferences->Java->Advanced->Screenshot Advanced Security Settings, towards the bottom of advanced tab

The screenshot for reference only
User-added image

A show support gathered off the server
How to generate a show support from Oneview or Extreme Management Center

Open a case with the GTAC 
How to contact Extreme Networks Global Technical Assistance Center (GTAC)
Resolution
1. Try clearing Java cache:

For Windows
Control Panel->Java->General->Temporary Internet Files->Settings->Delete Files->Select Cached files and applets

For MAC OS X
Applications->System Preferences->Java->General->Temporary Internet Files->Settings->Delete Files->Select Cached files and applets

2. Self signed certificate is applied to the NetSight server

Temporary workaround prior to 8.03.xx for Windows Users

a.  Stop EMC server.
      for linux OS - service nsserver stop

For Windows server service, see the following How to restart Netsight / Extreme Management Center services on linux or Windows Server Platforms

   Navigate to the location of the nsserver.keystore file on the Extreme Managment Center Server

b.      On Linux/Ubuntu, this will be /usr/local/Extreme_Networks/Netsight/wildfly/standalone/configuration
c.      On Windows installations, this will be \Program Files\Extreme Networks\Netsight\wildfly\standalone\configuration
d.     Rename the existing nsserver.keystore file "mv nsserver.keystore nsserver.keystore.old"
e.     Restart the server (restarting the server service (i.e., “service nsserver restart” on Linux) should suffice.
f.     Reconnect your client end system to the launch page or EMC and launch the legacy clients

On startup, the server should detect the missing keystore file and generate a new one with an OOB certificate.
Currently, there is no ability to used certificates other than the default. This should be corrected in 8.03.xx release.

Additional notes
This may not be your issue. Please see also
Common Issues: Unable to connect to NetSight Server Error
 

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