Can't find what you need?


• Ask the Community
• Create a Case
Reset Search
 

 

Article

MGMT-port-stays-down-after-upgrade

« Go Back

Information

 
TitleMGMT-port-stays-down-after-upgrade
Symptoms
  • MGMT port stays down after upgrade to the latest firmware. 
  • SNMP traps will not be sent by the switch to the trap receiver
  • Though MGMT port is down, you will be able to telnet, ping, send SNMP requests to the switch
Environment
  • Summit
  • Black Diamond
  • Following EXOS version and above:
    • 15.5.0.15
    • 15.4.2.1
    • 15.3.3.5-patch1-1
    • 15.3.1.4-patch1-26
    • 15.2.4.5-patch1-1            
    • 15.1.5.4-patch1-3
Cause
MGMT port of the switch connected to peer switch port where the Auto Negotiation is turned OFF, then, MGMT port stays in down state after upgrade to the firmware mentioned above or even higher versions. 

Below log message from the output of "debug ems show trace snmpmaster all" confirms that the SNMP trap receiver is not reachable via MGMT interface:

11/14/2014 02:52:53.332993 [5682] <snmpMaster:snmpMaster> SrcIpAndVrIdToTransportInfo: Destination not reachable via vrId 0 
11/14/2014 02:52:53.333036 [5683] <snmpMaster:snmpMaster> ../../snmpd/shared/notify.c(1540): SrGenerateNotifications: SrcIpAndVrIdToTransportInfo failed.
**"vrId 0" refers to MGMT interface. 
Resolution
CR xos0059204 and xos0056254 will fix the MGMT port staying in down state.  
Target Release(s):    
EXOS 15.6.1 (Released)
EXOS 15.3.5 (Released)
EXOS 15.5.4 (Released)

Workaround:
Enable Auto Negotiation setting on the peer switch as interim solution.
Additional notes

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255