Reset Search
 

 

Article

Mirror Port in GRE Tunnel setup does not work.

« Go Back

Information

 
TitleMirror Port in GRE Tunnel setup does not work.
Symptoms
  • Port is inactive.
  • Mirror Destination port is inactive
  • Cannot use all ports on Flow collector
Environment
  • S-Series
  • Coreflow 2
  • PV-FC-180 (see additional notes)
Cause

* The use of a GRE tunnel with a Coreflow2 switch type requires a unused physical port. The exception is the PV-FC-180 (see additional notes)
* If the unused physical port is an SFP port, an SFP module  must be populated.
 
Resolution
This is functioning as designed. This will not be fixed in a later version of firmware. It is a hardware limitation. However, the PV-FC-180 does not have this limitation.
 
Additional notes
This is a tentative mirror configuration that is then forwarded to a GRE tunnel which is then forwarded in this case to a Purview Appliance. It is only as a reference to show that port ge.1.3 will not physically be active. It is not a full configuration for GRE, policy mirror or for flow collection to GRE endpoint.
 
  1.  
set port duplex ge.1.3 full
set port speed ge.1.3 1000
set mirror create 1
set mirror 1 mirrorN 15
set mirror ports ge.1.3 1
  interface loop.0.1
              ip address 10.10.10.1 255.255.255.255 primary
              no shutdown
               exit
            interface tun.0.1
              tunnel destination 192.168.30.100
              tunnel mode gre l2 ge.1.3
              tunnel mirror enable
              tunnel source 10.10.10.1
              no shutdown
              exit

* if the port is a gigabit port (not 10G) then the port must be manually set for speed and duplex as above.
* If SFP, a module must be inserted for the L2 tunnel to become operational.

For PV-FC-180, a tbp (tunnel bridge port) can be used instead of a physical front panel port. This applied to firmware 8.42.01 and above on the PV-FC-180.
Here is a proposed configuration.
interface loop.0.1
ip address 1.1.2.1 mask 255.255.255.255 primary
no shutdown
!
interface tun.0.1
tunnel destination 1.1.1.1
tunnel mode gre l2 tbp.0.10
tunnel mirror enable
tunnel source 1.1.2.1
tunnel probe probe-name default
no shutdown
exit
!
set mirror create 1
set mirror 1 mirrorN 15
set mirror ports tbp.0.10 1
 

 

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255