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NAC Captive Portal SMS Verification Texts to T-Mobile Devices Arrive Blank

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TitleNAC Captive Portal SMS Verification Texts to T-Mobile Devices Arrive Blank
Symptoms
  • NAC Captive Portal
  • Blank SMS Verification text messages
  • T-Mobile cellular carrier
  • Code not received
Environment
All NAC Platforms
Cause
T-Mobile SMS/Email Servers strip out the body of any messages they receive without a "Subject" line. 
Resolution
  1. Select NAC Manager > Tools > Management and Configuration > Advanced Configuration > Portal Configurations > <Name_of_Portal_in_Use> > Web Site Configuration > Look & Feel > Message Strings
  2. Highlight the “registrationVerificationSMSSubject” Message String row
  3. Select the Edit selected Message button
  4. In the blank text-box, type in "WiFi Code: %VERIFY_CODE%" (without the enclosing quotation marks​)
Additional notes
By default, the “registrationVerificationSMSMsgBody” is populated with “Use this code in your browser to register: %VERIFY_CODE%” and the “registrationVerificationSMSSubject” is blank.  In this state, the T-Mobile SMS arrives with a blank Body and Subject (regardless of if the Mobile device is set to "Display Subject" or not).

Populating the Subject line 
radically changes the T-Mobile SMS behavior:  If the T-Mobile device is set to "Display Subject", it will now show both Subject and Body (as expected).  If the device is set to "Do Not Display Subject", it will just show the Body (which is the original intent of the SMS Verification).  

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