Reset Search
 

 

Article

Changing Web Credentials for NAC appliance/new NAC Appliance show green in NetSight Console but amber or red in NAC Manager

« Go Back

Information

 
TitleChanging Web Credentials for NAC appliance/new NAC Appliance show green in NetSight Console but amber or red in NAC Manager
Symptoms
  • NAC / EAC Appliance green in NetSight Console
  • NAC / EAC Appliance red in NAC Manager (NAC red icon)
  • NAC  / EAC Manager shows Status: Not Started or Unreachable
  • The new appliance is brought online, but cannot connect to Netsight/Extreme Management Center​
  • Upgrading XMC/NAC to 8.4.x from earlier versions result in NAC showing red in NAC manager. However, SNMP connectivity with XMC is established and therefore shows green in Devices.
Environment
  • All NetSight platforms
  • Newly added NAC Appliance
  • RMA NAC appliance
  • Non-default Web Services Credentials
  • EAC
  • Extreme Access Control
  • Extreme Management Center
Cause
Mis-matched Web Services Credentials
Resolution
  1. SSH into the new NAC Appliance
  2. Type /opt/nac/configWebCredentials <username> <password> to change the credentials
  3. Type nacctl restart to activate the new credentials
Additional notes
The above process, and other Web Services troubleshooting, is also available in the "NAC Deployment Guide" section of the NetSight "Help" webpages. 

This is where to find the credentials to use in step 2

NAC Manager
Tools > Management and Configuration >Advanced Configuration
Global and Appliances Settings> Appliance Settings > Default
Credentials tab > Web Service Credentials "NAC Appliance Web Service Credentials"
For use on Web Exrtreme Management Center see Where are the Admin Web Page Credentials for Extreme Control (NAC)
Also note that the default NAC web credentials for 6.2 NAC systems and VMware is Enterasysn@c.  As of 6.3, the new credentials are Extreme@pp

------------
Possible output errors from nacstatus output
#-------------------------------------------------------------------------------
# Communications Diagnostics
#-------------------------------------------------------------------------------

NAC to NetSight WebServices:           FAILURE.
NetSight to NAC WebServices:           UNABLE TO TEST.
JMS Topic Connection:                  DOWN.

--------
Errors from /var/logs/tag.log

2017-07-06 08:19:00,320 ERROR [NacEndSystemWebServiceClient] Cannot verify web services connection to NAC management server: 192.168.1.101; no credentials
2017-07-06 08:19:29,864 ERROR [NacEndSystemWebServiceClient] Cannot verify web services connection to NAC management server: 192.168.1.101; no credentials

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255