Reset Search
 

 

Article

S Series VXLan not passing traffic

« Go Back

Information

 
TitleS Series VXLan not passing traffic
Symptoms
client attached to one S Series was not receiving traffic through the vxlan tunnel from the clients on the other side.
Environment
  • S series
  • firmware 8.42.01.0007
  • VXLan over routed environment
Cause
The tunnel port was not properly added to the configuration.  The routing was working as expected and the tunnel was configured correctly.  The tunnel port tbp.0.1 was not in the egress list for the vlan.
Resolution
configure terminal
!
 interface loop.0.1
  ip address 40.40.40.40 255.255.255.255 primary
  no shutdown
  exit
 interface vlan.0.10
  ip address 100.100.10.4 255.255.255.0 primary
  no shutdown
  exit
 interface vlan.0.40
  ip address 200.100.40.1 255.255.255.252 primary
  ip ospf network point-to-point
  no shutdown
  exit
 interface tun.0.1
  tunnel mode vxlan l2 tbp.0.1
  tunnel source 40.40.40.40
  no shutdown
  exit
!
!
!
 router ospf 1
  router-id 100.100.100.40
  network 40.40.40.40 0.0.0.0 area 0.0.0.0
  network 200.100.40.0 0.0.0.3 area 0.0.0.0
  log-adjacency
  exit


# port
set port vlan tbp.0.1 10
set port vlan ge.1.40 10
# tunnel
set tunnel logical-switch create name vlan10
set tunnel map logical-switch vlan10 keyword 10 vlan 10
set tunnel remote-vtep logical-switch vlan10 ip-address 30.30.30.30
set tunnel remote-vtep logical-switch vlan10 ip-address 20.20.20.20
!
# vlan
set vlan create 10,40
clear vlan egress 1 tbp.0.1;ge.1.40
set vlan egress 10 tbp.0.1;ge.1.40 untagged
set vlan egress 40 ge.1.25 tagged
!



 
Additional notes

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255