Reset Search
 

 

Article

S-Series f/w 7.02 Configuring Loopback Interfaces for Passive OSPF

« Go Back

Information

 
TitleS-Series f/w 7.02 Configuring Loopback Interfaces for Passive OSPF
Symptoms
Attempting to explicitly set a loopback interface to passive mode is no longer permitted, and generates an error message:
Error: All loopback interfaces are passive by default.
Environment
  • S-Series
  • Firmware 7.02.02.0002 and 7.02.03.0001
Cause
  • Configured one or more loopback interfaces for OSPF.
  • For example:
S4 Chassis(su-config-ospf-1)->show running-config
# **** VRF default (default) ****
configure terminal
!
interface loop.0.1
 ip address 192.168.200.1 255.255.255.255 primary
 no shutdown
 exit
interface loop.0.2
 ip address 10.0.0.1 255.255.255.255 primary
 no shutdown
 exit
interface vlan.0.10
 ip address 192.168.10.10 255.255.255.0 primary
 ip ospf priority 255
 no shutdown
exit
 interface vlan.0.100
 ip address 192.168.100.10 255.255.255.0 primary
 no shutdown
exit
!
# Static routes configured on routed interfaces
!
# Static routes configured on non-routed interfaces
!
router ospf 1
 router-id 1.1.1.1
 network 10.0.0.1 0.0.0.0 area 0.0.0.0
 network 192.168.10.0 0.0.0.255 area 0.0.0.0
 network 192.168.100.0 0.0.0.255 area 0.0.0.0
 network 192.168.200.1 0.0.0.0 area 0.0.0.0
 log-adjacency
 exit
!
exit
!
S4 Chassis(su-config-ospf-1)->
  • Then, configured a loopback interface for "passive mode" so that it does not send OSPF updates.
  • For example:
S4 Chassis(su-config-ospf-1)->passive-interface loop.0.1
S4 Chassis(su-config-ospf-1)->
Symptoms
The system applies the passive-interface command on the vlan (vs loop) interface;
  -and-
All other OSPF-member loopback interfaces also have the command applied to them.

For example:

S4 Chassis(su-config-ospf-1)->show running-config
# **** VRF default (default) ****
configure terminal
!
interface loop.0.1
 ip address 192.168.200.1 255.255.255.255 primary
 no shutdown
 exit
interface loop.0.2
 ip address 10.0.0.1 255.255.255.255 primary
 no shutdown
 exit
interface vlan.0.10
 ip address 192.168.10.10 255.255.255.0 primary
 ip ospf priority 255
 no shutdown
 exit
 interface vlan.0.100
 ip address 192.168.100.10 255.255.255.0 primary
 no shutdown
 exit
!
# Static routes configured on routed interfaces
!
# Static routes configured on non-routed interfaces
!
router ospf 1
 router-id 1.1.1.1
 network 10.0.0.1 0.0.0.0 area 0.0.0.0
 network 192.168.10.0 0.0.0.255 area 0.0.0.0
 network 192.168.100.0 0.0.0.255 area 0.0.0.0
 network 192.168.200.1 0.0.0.0 area 0.0.0.0
 log-adjacency
 passive-interface vlan 1
 passive-interface vlan 2
 exit
!
exit
!
S4 Chassis(su-config-ospf-1)->
Resolution
Upgrade to firmware 7.03.03.0001 or higher.
Additional notes

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255