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SSA: Reset with Fault Log message: Assertion failed: SOC_REG_IS_VALID

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TitleSSA: Reset with Fault Log message: Assertion failed: SOC_REG_IS_VALID
Symptoms
  • Blade Reset
  • Core File 
  • Fault Log Message:
  • Assertion failed: SOC_REG_IS_VALID
  • <3>bcmStrat[1.tNimIntr]MEM_FAIL interrupt occurred on chip 9!
Full Message: 

<0>Default[1.tNimIntr]Assertion failed: SOC_REG_IS_VALID(unit, reg), file /firmware/common/bcmStrataDrv/04_12_50/sdk/src/soc/common/./reg.c, line 2897 ( 0x00dcd2dc 0x004108f8 0x010a9d80 0x010ad244 0x00ea94b4 0x00e9e82c 0x00444bc4 0x0046e4ec 0x0046ee40 0x019eec64 0xeeeeeeee )
Environment
  • S-Series
  • SSA-T1068-0652A
  • Firmware: 8.22.02.0012
Cause
The error handler was attempting to access a register that did not exist on the failing XGS MAC device.  Added the correct decodes for this device. This is likely to be an extremely rare occurrence.
Resolution
Upgrade to firmware 8.31.02.0015
Additional notes

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