Reset Search
 

 

Article

Switch is not showing port information in NAC

« Go Back

Information

 
TitleSwitch is not showing port information in NAC
Symptoms
  • When viewing the End System information that switch port is not displayed.
  • The Switch in question also shows lost contact within the NAC appliance webview > Status > Switches/Routers screen.
  • SNMP debug shows the following in the log for the NAC appliance:  
2019-08-21 10:23:20,470 WARN [SnmpManager] Recieved Authentication Failure: SNMP_V3_NOT_IN_TIME_WINDOW(1411) from device: 10.58.36.220 with message: org.snmp4j.asn1.BERInputStream@77e4656a 

2019-08-21 10:23:20,470 WARN [SnmpManager] Device with IP 10.58.36.220 has duplicate SNMP Engine ID: 80:00:07:7c:03:00:05:a3:c0:b7:6d - ID already assigned to 10.58.36.210

 
Environment
  • Extreme Management Center
  • NAC Manager
  • Extreme Access Control
  • Summit
Cause
One switch was added with the same SNMP information as another switch, which also included the snmp engine-ID
Resolution
1.  On the switches enter the following to commands:  show snmpv3 engine-info and  show switch

Sample output:

show snmpv3 engine-info 
SNMP Engine-ID : 80:00:07:7c:03:00:0c:29:46:98:dd 'H' 
SNMP Engine Boots : 63 
SNMP Engine Time : 331424 
SNMP Max. Message Size : 8192

show switch
SysName: EXOS-VM 
SysLocation: 
SysContact: support@extremenetworks.com, +1 
System MAC: 00:0C:29:46:98:DD 

You will notice that the system MAC address is used as part of the SNMP Engine-ID. In the above example there is a line in the snmp portion of the config for:   configure snmpv3 engine-id 03:00:0c:29:46:98:dd 


2.  On the switch where these entries do no match, issue the command (note the 03 at the start of the engine-ID):  
configure snmpv3 engine-id 03:<the MAC address of the switch>

This will remove the 'configure snmpv3 add user' line from the config. You will need to add that back in so that it uses the new engine-ID.  For example:

configure snmpv3 add user snmpuser authentication md5 <authpassword> privacy des <privpassword>

3.  Restart the snmpMaster + snmpSubAgent processes on the switch:
How do I restart the snmp process? there is snmpmaster and snmpsubagent

4.  In the NAC appliance webview > Status > Switches/Routers screen click the Clear button under the Cached Data column for that switch.
Additional notes

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255