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Switch stops sending RADIUS Requests or does not acknowledge RADIUS Accepts

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TitleSwitch stops sending RADIUS Requests or does not acknowledge RADIUS Accepts
Symptoms
Switch stops sending RADIUS Requests or does not acknowledge RADIUS Accepts
An instance of this issue was found to be related to NESSUS Security Scan, which may have injected RADIUS packets throughout the network
Environment
  • K-Series
  • S-Series
  • Seen in Firmware Version 08.42.01.xx and prior
Cause
  • There is a chance when certain abnormal packets are received for the RADIUS process to get into a hung state. This behavior is exhibited differently for S and K. For S the system may stop sending RADIUS Requests while for K-Series the system may send the request but not acknowledge the response.
  • An instance of this issue was found to be related to NESSUS Security Scan, which may have injected RADIUS packets throughout the network
  • Release notes show the following as fixed in 08.42.02.xx:
Receiving corrupted RADIUS frames may cause improper processing of future RADIUS
requests.
Resolution
Once in this condition a reset of the system is required to clear the condition. Engineering has enhanced RADIUS functionality to prevent this condition which will be available in firmware 8.42.02 and later releases.
A temporary fix is to reset the manager unit blade, which can be determined by either going local to chassis and seeing which LED for MGR is lit up, or by finding the following lines in a show support output:
Distribution Master:                                     Yes
My Slot Number:                                            2
The Manager blade will display "Yes" while non-management blades display "No"
Additional notes

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