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Unable to log into Extreme Management Center with http 404 error

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TitleUnable to log into Extreme Management Center with http 404 error
Symptoms
  • Accessing Extreme Management Center presents http 404 error
  • Server.log on the Extreme Management Center server displays following error:  2017-10-30 01:00:00,021 ERROR [com.enterasys.netsight.database.mysql.partition.AlarmHistoryUtil] com.enterasys.netsight.database.mysql.partition.PartitionException
Environment
  • NetSight
  • Extreme Management Center
  • Console
  • NAC Manager
  • Policy Manager
Cause
The nslarms and nsalarmhisotry tables are correct in the database.
Resolution
Do the following on the Extreme Management server:

1. Make a backup of the current Extreme Management database. 

2. Shutdown the Extreme Management server, but not the mysql server. You can do that with the command: 

Linux:
service nsserver stop 

Windows:
Do this from Services. The service name is NetSight Server Service

3. CD into /NetSight_install_path/NetSight/scripts (replace /NetSight_install_path with the correct path for you system). Issue the command: ./mysql.sh 

On Windows the path is: C:\Program Files\Extreme Networks\NetSight\scripts\
Issue the command:  mysql.cmd

4. At the MySQL prompt issue the command: 
    drop table netsightrpt.nsalarms; 
    drop table netsightrpt.nsalarmhistory; 
  
5. Quit mysql 
  
6. Shutdown mysql server with the command: service nsdatabase stop 

Windows:
Do this from Services.  The service name is NetSight Database Service.
  
7. Go into the /NetSight_Install_path/NetSight/mysql/data/netsightrpt folder. Delete all the files that have nsalarms and nsalarmhistory in the name. The nsalarmhistory table is partitioned, so there may be quite a few. There may be no files if drop worked correctly. 
  
8. Start the mysql server (but not the server service): service nsdatabase start 
Windows:
Do this from Services.  The service name is NetSight Database Service.
  
9. Go to the MySQL prompt and drop those tables again. 
    drop table netsightrpt.nsalarms; 
    drop table netsightrpt.nsalarmhistory; 

There may be errors due to being corrupt or there may be errors because they are already gone. 
  
9. Now we have to verify that they are finally gone. At the MySQL prompt issue the command: show tables in netsightrpt; 
  
Verify that the nsalarms and nsalarmhistory tables are really gone. 
  
10. Start NetSight back up: service nsserver start 
Windows:
Do this from Services. The service name is NetSight Server Service

You can watch the log on linux to see when the  start-up completes: 

tail-f /NetSight_install_path/NetSight/appdata/logs/server.log 
  
11. Go to the mysql prompt and issue command: show tables in netsightrpt; 
The tables should be back – Extreme Management should have created them at startup. 
Additional notes

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