Reset Search
 

 

Article

fspf daemon process crash

« Go Back

Information

 
Titlefspf daemon process crash
Symptoms
  • Unexpected management module reload or high availability/HA failover
  • Issue occurs using this network topology
    VDX8770--------ISL/VLAG------VDX6740
  • fspf daemon process crash on VDX8770 
    2018/06/06-14:21:37, [HASM-1201], 23623, M2 | Active | FFDC, WARNING, VDX8770-8, fspf:4610 failed to refresh (992862942:992862355, kill-6).
    2018/06/06-14:22:30, [HASM-1200], 23639, M2 | Active | FFDC, WARNING, VDX8770-8, Detected termination of process fspfd:4610.
    2018/06/06-14:22:30, [HASM-1000], 23641, M2 | Active, CRITICAL, VDX8770-8, Daemon fspf terminated. System initiated reload/failover for recovery.
  • crash occurs after issuing a "no shutdown" and "shutdown" on ISL vLAG interface of VDX6740 
    sw0(config)# int Te 1/0/50:1
    sw0(conf-if-te-1/0/50:1)# no shutdown
    sw0(conf-if-te-1/0/50:1)# end
    sw0# conf terminal
    Entering configuration mode terminal
    sw0(config)# int te 1/0/50:1
    sw0(conf-if-te-1/0/50:1)# shutdown
  • switch keeps on logging RTWR retries
  • "no fabric trunk enable" configured on port-channel member on VDX6740
    interface TenGigabitEthernet 1/0/50:1
     channel-group 10 mode active type standard
     no fabric isl enable
     no fabric trunk enable
     lacp timeout short
     no shutdown
  • "vLAG" configured on port-channel on VDX6740
    interface Port-channel 10
     vlag ignore-split
     mtu 9216
     switchport
     switchport mode trunk
     switchport trunk allowed vlan all
     switchport trunk tag native-vlan
     spanning-tree shutdown
     no shutdown
  • "fabric trunk enable" configured on port-channel member on VDX8770
    interface TenGigabitEthernet 1/1/35
     channel-group 1000 mode active type standard
     no fabric isl enable
     fabric trunk enable
     lacp timeout short
     no shutdown
  • "vLAG" configured on port-channel on VDX8770
    interface Port-channel 1000
     vlag ignore-split
     mtu 9216
     switchport
     switchport mode trunk
     switchport trunk allowed vlan all
     switchport trunk tag native-vlan
     spanning-tree shutdown
     no shutdown
Environment
  • VDX 8770 Series
  • Network OS
Cause
This issue is caused by mis-configured interface transitioning (shutdown/no shutdown) thereby becoming a vLAG port and at the same time a fabric port. 
The conflict of vLAG and fabric trunk results in a fabric issue with either (fspfd/nsmd) or both not being able to work as designed. This ultimately ends with these daemons unexpectedly terminating causing KSWD and FFDC in kernel panic.
Resolution
Do not configure the same interface as a vLAG port-channel and Fabric trunk port.
Additional notes

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255